using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\*[\s\S]*?(.*?)\*\/)|(\/\/.*)";
string input = @"/*
function to do things with
*/
function myFunction() {
this.x=55; //Some value
//start the function
this.start();
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}