package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/\*[\s\S]*?(.*?)\*\/)|(\/\/.*)`)
var str = `/*
function to do things with
*/
function myFunction() {
this.x=55; //Some value
//start the function
this.start();
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}