using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\-?\d+(?:\.\d+)?(?= *=)|\-?\d+(?:\.\d+)?$";
string input = @"6 = 2*3
2*3 = 6
-6 = 2*4 - 2
2*4 - 2 = -6
3.24 = 3 * 1.08
-3 * 1.08 = -3.24
6 = 3!
3! = 6
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}