re = /^\-?\d+(?:\.\d+)?(?= *=)|\-?\d+(?:\.\d+)?$/m
str = '6 = 2*3
2*3 = 6
-6 = 2*4 - 2
2*4 - 2 = -6
3.24 = 3 * 1.08
-3 * 1.08 = -3.24
6 = 3!
3! = 6
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end