import re
regex = re.compile(r"^\-?\d+(?:\.\d+)?(?= *=)|\-?\d+(?:\.\d+)?$", flags=re.MULTILINE)
test_str = ("6 = 2*3\n"
"2*3 = 6\n"
"-6 = 2*4 - 2\n"
" 2*4 - 2 = -6\n"
"3.24 = 3 * 1.08\n"
"-3 * 1.08 = -3.24\n"
"6 = 3!\n"
"3! = 6\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")