import Foundation
let pattern = #"^\-?\d+(?:\.\d+)?(?= *=)|\-?\d+(?:\.\d+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
6 = 2*3
2*3 = 6
-6 = 2*4 - 2
2*4 - 2 = -6
3.24 = 3 * 1.08
-3 * 1.08 = -3.24
6 = 3!
3! = 6
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)