const regex = new RegExp('^\\-?\\d+(?:\\.\\d+)?(?= *=)|\\-?\\d+(?:\\.\\d+)?$', 'gm')
const str = `6 = 2*3
2*3 = 6
-6 = 2*4 - 2
2*4 - 2 = -6
3.24 = 3 * 1.08
-3 * 1.08 = -3.24
6 = 3!
3! = 6
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}