#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*)"
Local $sString = "https://senvang.asia/màn-hình-led/?p=10trieu" & @CRLF & _
"https://senvang.asia/màn-hình-led/" & @CRLF & _
"https://senvang.asia/lien-he/" & @CRLF & _
"https://senvang.asia/lien-he" & @CRLF & _
"https://senvang.asia/lien-he/xinchafo" & @CRLF & _
"" & @CRLF & _
"https://senvang.asia/liên-con-hệ-nhà-bà-lạc/?p=10trieu" & @CRLF & _
"" & @CRLF & _
"https://senvang.asia/m%C3%A0n-h%C3%ACnh-led/trong-nh%C3%A0/li%C3%AAn-con-h%E1%BB%87-nh%C3%A0-b%C3%A0-l%E1%BA%A1c" & @CRLF & _
"" & @CRLF & _
"https://senvang.asia/màn-hình-led/?p=10trieu" & @CRLF & _
"" & @CRLF & _
"https://senvang.asia/màn-hình-led/trong-nhà/?p=duoi-10-trieu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")