import Foundation
let pattern = #"(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://senvang.asia/màn-hình-led/?p=10trieu
https://senvang.asia/màn-hình-led/
https://senvang.asia/lien-he/
https://senvang.asia/lien-he
https://senvang.asia/lien-he/xinchafo
https://senvang.asia/liên-con-hệ-nhà-bà-lạc/?p=10trieu
https://senvang.asia/m%C3%A0n-h%C3%ACnh-led/trong-nh%C3%A0/li%C3%AAn-con-h%E1%BB%87-nh%C3%A0-b%C3%A0-l%E1%BA%A1c
https://senvang.asia/màn-hình-led/?p=10trieu
https://senvang.asia/màn-hình-led/trong-nhà/?p=duoi-10-trieu
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)