// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)").unwrap();
let string = "https://senvang.asia/màn-hình-led/?p=10trieu
https://senvang.asia/màn-hình-led/
https://senvang.asia/lien-he/
https://senvang.asia/lien-he
https://senvang.asia/lien-he/xinchafo
https://senvang.asia/liên-con-hệ-nhà-bà-lạc/?p=10trieu
https://senvang.asia/m%C3%A0n-h%C3%ACnh-led/trong-nh%C3%A0/li%C3%AAn-con-h%E1%BB%87-nh%C3%A0-b%C3%A0-l%E1%BA%A1c
https://senvang.asia/màn-hình-led/?p=10trieu
https://senvang.asia/màn-hình-led/trong-nhà/?p=duoi-10-trieu";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}