re = /(.*)/m
str = 'https://senvang.asia/màn-hình-led/?p=10trieu
https://senvang.asia/màn-hình-led/
https://senvang.asia/lien-he/
https://senvang.asia/lien-he
https://senvang.asia/lien-he/xinchafo
https://senvang.asia/liên-con-hệ-nhà-bà-lạc/?p=10trieu
https://senvang.asia/m%C3%A0n-h%C3%ACnh-led/trong-nh%C3%A0/li%C3%AAn-con-h%E1%BB%87-nh%C3%A0-b%C3%A0-l%E1%BA%A1c
https://senvang.asia/màn-hình-led/?p=10trieu
https://senvang.asia/màn-hình-led/trong-nhà/?p=duoi-10-trieu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end