# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)"
test_str = ("https://senvang.asia/màn-hình-led/?p=10trieu\n"
"https://senvang.asia/màn-hình-led/\n"
"https://senvang.asia/lien-he/\n"
"https://senvang.asia/lien-he\n"
"https://senvang.asia/lien-he/xinchafo\n\n"
"https://senvang.asia/liên-con-hệ-nhà-bà-lạc/?p=10trieu\n\n"
"https://senvang.asia/m%C3%A0n-h%C3%ACnh-led/trong-nh%C3%A0/li%C3%AAn-con-h%E1%BB%87-nh%C3%A0-b%C3%A0-l%E1%BA%A1c\n\n"
"https://senvang.asia/màn-hình-led/?p=10trieu\n\n"
"https://senvang.asia/màn-hình-led/trong-nhà/?p=duoi-10-trieu")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.