const regex = /(\G(?!\A)\w+|\b(?:where|there)\b)\./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\G(?!\\A)\\w+|\\b(?:where|there)\\b)\\.', 'g')
const str = `hey where.is.the book on.brown.table
hey there.is.a.boy.in.the city Delhi
hey here.is.the.boy living next door`;
const subst = `$1_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);