use strict;
my $str = 'hey where.is.the book on.brown.table
hey there.is.a.boy.in.the city Delhi
hey here.is.the.boy living next door';
my $regex = qr/(\G(?!\A)\w+|\b(?:where|there)\b)\./p;
my $subst = '$1_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";