$re = '/(\G(?!\A)\w+|\b(?:where|there)\b)\./';
$str = 'hey where.is.the book on.brown.table
hey there.is.a.boy.in.the city Delhi
hey here.is.the.boy living next door';
$subst = "$1_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;