import Foundation
let pattern = #"(\G(?!\A)\w+|\b(?:where|there)\b)\."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
hey where.is.the book on.brown.table
hey there.is.a.boy.in.the city Delhi
hey here.is.the.boy living next door
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)