using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+?\s(.*)";
string substitution = @"$1";
string input = @"50G This is a Test (0000) 1234p (String).ext";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}