package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.+?\s(.*)`)
var str = `50G This is a Test (0000) 1234p (String).ext`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}