import re
regex = re.compile(r"^.+?\s(.*)", flags=re.MULTILINE)
test_str = "50G This is a Test (0000) 1234p (String).ext"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)