re = /^.+?\s(.*)/m
str = '50G This is a Test (0000) 1234p (String).ext'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result