use strict;
my $str = '50G This is a Test (0000) 1234p (String).ext';
my $regex = qr/^.+?\s(.*)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";