# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[a-z]([A-Z])/\1/gm;t' <<< "aDepartment of test, kHospital of test"