$re = '/[a-z]([A-Z])/m';
$str = 'aDepartment of test, kHospital of test';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;