import re
regex = re.compile(r"[a-z]([A-Z])", flags=re.MULTILINE)
test_str = "aDepartment of test, kHospital of test"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)