re = /[a-z]([A-Z])/m
str = 'aDepartment of test, kHospital of test'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result