const regex = new RegExp('[a-z]([A-Z])', 'gm')
const str = `aDepartment of test, kHospital of test`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);