#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^"\r\n]+(?:"[^"]*"[^"\r\n]+)*"
Local $sString = "Row 1: bla bla, 12345," & @CRLF & _
"Row 2: "bla" & @CRLF & _
"bla", 12345, ..." & @CRLF & _
"Row 3: bla bla, 12345,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")