const regex = /[^"\r\n]+(?:"[^"]*"[^"\r\n]+)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^"\\r\\n]+(?:"[^"]*"[^"\\r\\n]+)*', 'gm')
const str = `Row 1: bla bla, 12345,
Row 2: "bla
bla", 12345, ...
Row 3: bla bla, 12345,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}