re = /[^"\r\n]+(?:"[^"]*"[^"\r\n]+)*/m
str = 'Row 1: bla bla, 12345,
Row 2: "bla
bla", 12345, ...
Row 3: bla bla, 12345,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end