using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^""\r\n]+(?:""[^""]*""[^""\r\n]+)*";
string input = @"Row 1: bla bla, 12345,
Row 2: ""bla
bla"", 12345, ...
Row 3: bla bla, 12345,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}