$re = '/[^"\r\n]+(?:"[^"]*"[^"\r\n]+)*/m';
$str = 'Row 1: bla bla, 12345,
Row 2: "bla
bla", 12345, ...
Row 3: bla bla, 12345,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);