import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\"Assigned Workgroup\" in \\()[\"?\\w\"?|,]*\\\"(Business Service Management)";
final String string = "project in (KISHORE_TEST, \"Business Service Management\") AND \"Assigned Workgroup\" in (KISHORE_TEST,\"Business Service Management\", \"Account\",\"BSM Automation\") OR \"Workgroup\" in (\"BSM Automation\") OR \"Assigned Workgroup\" in (\"Business Service Management\",\"BSM Automation\") AND \"Assigned Workgroup\" in (\"KISHORE_TEST\",\"Business Service Management\", \"Account\",\"BSM Automation\") OR \"Assigned Workgroup\" in (\"BSM Automation\") and team = \"Business Service Management\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}