use strict;
my $str = 'project in (KISHORE_TEST, "Business Service Management") AND "Assigned Workgroup" in (KISHORE_TEST,"Business Service Management", "Account","BSM Automation") OR "Workgroup" in ("BSM Automation") OR "Assigned Workgroup" in ("Business Service Management","BSM Automation") AND "Assigned Workgroup" in ("KISHORE_TEST","Business Service Management", "Account","BSM Automation") OR "Assigned Workgroup" in ("BSM Automation") and team = "Business Service Management"';
my $regex = qr/(?<="Assigned Workgroup" in \()["?\w"?|,]*\"(Business Service Management)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}