const regex = /(?<="Assigned Workgroup" in \()["?\w"?|,]*\"(Business Service Management)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<="Assigned Workgroup" in \\()["?\\w"?|,]*\\"(Business Service Management)', 'gm')
const str = `project in (KISHORE_TEST, "Business Service Management") AND "Assigned Workgroup" in (KISHORE_TEST,"Business Service Management", "Account","BSM Automation") OR "Workgroup" in ("BSM Automation") OR "Assigned Workgroup" in ("Business Service Management","BSM Automation") AND "Assigned Workgroup" in ("KISHORE_TEST","Business Service Management", "Account","BSM Automation") OR "Assigned Workgroup" in ("BSM Automation") and team = "Business Service Management"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}