import re
regex = re.compile(r"(?<=\"Assigned Workgroup\" in \()[\"?\w\"?|,]*\"(Business Service Management)", flags=re.MULTILINE)
test_str = "project in (KISHORE_TEST, \"Business Service Management\") AND \"Assigned Workgroup\" in (KISHORE_TEST,\"Business Service Management\", \"Account\",\"BSM Automation\") OR \"Workgroup\" in (\"BSM Automation\") OR \"Assigned Workgroup\" in (\"Business Service Management\",\"BSM Automation\") AND \"Assigned Workgroup\" in (\"KISHORE_TEST\",\"Business Service Management\", \"Account\",\"BSM Automation\") OR \"Assigned Workgroup\" in (\"BSM Automation\") and team = \"Business Service Management\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")