re = /(?<="Assigned Workgroup" in \()["?\w"?|,]*\"(Business Service Management)/m
str = 'project in (KISHORE_TEST, "Business Service Management") AND "Assigned Workgroup" in (KISHORE_TEST,"Business Service Management", "Account","BSM Automation") OR "Workgroup" in ("BSM Automation") OR "Assigned Workgroup" in ("Business Service Management","BSM Automation") AND "Assigned Workgroup" in ("KISHORE_TEST","Business Service Management", "Account","BSM Automation") OR "Assigned Workgroup" in ("BSM Automation") and team = "Business Service Management"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end