# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/(?=[^\/]{5}(?:\/| |$))/ /gm;t' <<< "07070 should give me 07070
07070/01010 should give me 07070 01010
0/0/0/BBBBB should give me 0/0/0 BBBBB
AAAAA/BBBBB/CCCCC should give me AAAAA BBBBB CCCCCC"