import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/(?=[^/]{5}(?:/| |$))";
final String string = "07070 should give me 07070\n"
+ "07070/01010 should give me 07070 01010\n"
+ "0/0/0/BBBBB should give me 0/0/0 BBBBB\n"
+ "AAAAA/BBBBB/CCCCC should give me AAAAA BBBBB CCCCCC";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}