re = /\/(?=[^\/]{5}(?:\/| |$))/m
str = '07070 should give me 07070
07070/01010 should give me 07070 01010
0/0/0/BBBBB should give me 0/0/0 BBBBB
AAAAA/BBBBB/CCCCC should give me AAAAA BBBBB CCCCCC'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result