using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/(?=[^/]{5}(?:/| |$))";
string substitution = @" ";
string input = @"07070 should give me 07070
07070/01010 should give me 07070 01010
0/0/0/BBBBB should give me 0/0/0 BBBBB
AAAAA/BBBBB/CCCCC should give me AAAAA BBBBB CCCCCC";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}