use strict;
my $str = '07070 should give me 07070
07070/01010 should give me 07070 01010
0/0/0/BBBBB should give me 0/0/0 BBBBB
AAAAA/BBBBB/CCCCC should give me AAAAA BBBBB CCCCCC';
my $regex = qr~/(?=[^/]{5}(?:/| |$))~mp;
my $subst = ' ';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";