#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)\b(?:field[1234])=\S+\b(?=.*\btype=a\b)" & @CRLF & _
"|" & @CRLF & _
"(?<=\btype=a\b.*)\b(?:field[1234])=\S+\b"
Local $sString = "field1=foo this=garbage field2=bar type=a field3=now" & @CRLF & _
"field1=foo field2=bar type=b field3=now" & @CRLF & _
"field1=bar type=a field3=foo this=garbage field4=hithere" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")