using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:field[1234])=\S+\b(?=.*\btype=a\b)
|
(?<=\btype=a\b.*)\b(?:field[1234])=\S+\b";
string input = @"field1=foo this=garbage field2=bar type=a field3=now
field1=foo field2=bar type=b field3=now
field1=bar type=a field3=foo this=garbage field4=hithere
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}