import Foundation
let pattern = #"""
\b(?:field[1234])=\S+\b(?=.*\btype=a\b)
|
(?<=\btype=a\b.*)\b(?:field[1234])=\S+\b
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
field1=foo this=garbage field2=bar type=a field3=now
field1=foo field2=bar type=b field3=now
field1=bar type=a field3=foo this=garbage field4=hithere
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)