import re
regex = re.compile(r"""
\b(?:field[1234])=\S+\b(?=.*\btype=a\b)
|
(?<=\btype=a\b.*)\b(?:field[1234])=\S+\b
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("field1=foo this=garbage field2=bar type=a field3=now\n"
"field1=foo field2=bar type=b field3=now\n"
"field1=bar type=a field3=foo this=garbage field4=hithere\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")