import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:field[1234])=\\S+\\b(?=.*\\btype=a\\b)\n"
+ "|\n"
+ "(?<=\\btype=a\\b.*)\\b(?:field[1234])=\\S+\\b";
final String string = "field1=foo this=garbage field2=bar type=a field3=now\n"
+ "field1=foo field2=bar type=b field3=now\n"
+ "field1=bar type=a field3=foo this=garbage field4=hithere\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}