#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\S+\s){4}(?<fifthword>\S+)\s(?<sixthword>\S+)"
Local $sString = "2023-01-22T08:50:53.642034+02:00 Forwarder-Kali sudo: meow : user NOT in sudoers ; TTY=pts/3 ; PWD=/root ; USER=root ; COMMAND=/usr/bin/cat /etc/passwd "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")