import Foundation
let pattern = #"^(?:\S+\s){4}(?<fifthword>\S+)\s(?<sixthword>\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2023-01-22T08:50:53.642034+02:00 Forwarder-Kali sudo: meow : user NOT in sudoers ; TTY=pts/3 ; PWD=/root ; USER=root ; COMMAND=/usr/bin/cat /etc/passwd "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)