using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\S+\s){4}(?<fifthword>\S+)\s(?<sixthword>\S+)";
string input = @"2023-01-22T08:50:53.642034+02:00 Forwarder-Kali sudo: meow : user NOT in sudoers ; TTY=pts/3 ; PWD=/root ; USER=root ; COMMAND=/usr/bin/cat /etc/passwd ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}