#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,6})*$"
Local $sString = "name@domain.com" & @CRLF & _
"name@" & @CRLF & _
"namedomain.com" & @CRLF & _
"domain.com" & @CRLF & _
"firstname.lastname@domain.com" & @CRLF & _
"name@subdomain.domain.com" & @CRLF & _
"firstname+lastname@example.com " & @CRLF & _
"firstname_lastname@domain.com" & @CRLF & _
"firstname-lastname_test@domain.com" & @CRLF & _
"firstname$$@domain.com" & @CRLF & _
"" & @CRLF & _
"// You can see the original post at albertcolom.com/blog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")